quickshell-web/flake.nix
outfoxxed a787497feb
nix packaging
Still requires manual addition of modules and tweaking pagefind.
2024-09-28 02:26:13 -07:00

17 lines
408 B
Nix

{
inputs = {
nixpkgs.url = "nixpkgs/nixos-unstable";
};
outputs = { self, nixpkgs }: let
forEachSystem = fn: nixpkgs.lib.genAttrs
[ "x86_64-linux" "aarch64-linux" ]
(system: fn system nixpkgs.legacyPackages.${system});
in {
packages = forEachSystem (system: pkgs: rec {
quickshell-web = pkgs.callPackage ./default.nix {};
default = quickshell-web;
});
};
}